# Table of Contents

## Introduction

- About this Class ........................................ 4
- Topics ..................................................... 4

## Required Skills

- Other requirements ...................................... 5

## Organization

- Projects ...................................................... 6
- Pages .......................................................... 7
- Actions .......................................................... 9

## Inserting Content

- Text and Headers/Footers ................................ 11
- Headers and Footers ......................................... 12
- Multimedia .................................................. 13
- Embedding Content ........................................ 15
- Google Docs .................................................. 15
- Google Forms ............................................... 16
- Qualtrics Surveys .............................................. 17
- Widgets and Other Web Content ......................... 18
- Buttons, Speech Bubble, and Tab Box ..................... 19
- Buttons ......................................................... 19
- Speech Bubble ............................................... 20
- Tab Box .......................................................... 20
- Dialogue ........................................................ 21

## Quizzes

- Quiz Questions ........................................... 23
- Scoring .......................................................... 25

## Saving and Exporting

- Saving and Exporting ...................................... 26
- Uploading to the Web ......................................... 27
Introduction

Case Scenario/Critical Reader Builder (CS/CR) is a desktop tool for creating web-based learning materials. It uses a combination of text, audio, video, and quizzes organized into branching simulated narratives to guide students through an interactive learning environment.

The builder will take a project and then export it to a case scenario viewable with any modern web browser. This case scenario can then be made available to students where they can explore a subject intuitively, rather than obtaining knowledge in a linear fashion.

About this Class

This manual will serve as a reference for the various capabilities of the CS/CR Builder in the context of the 7Cs which provide a conceptual framework for designing a case scenario. We will begin with adding content and inserting images, audio, and video to individual pages developing context for students taking the class. Next we will work on embedding content from the web and creating interactive quizzes.

Topics

The following topics will be covered throughout the course of the manual.

- Creating a Project
- Adding Pages
- Adding Sections and Content to Pages
- Inserting Images
- Inserting Video/Audio
- Attaching Documents
- Attaching Actions
- Embedded Content
- User Interactivity
- Exporting and Saving
Required Skills

Using CS/CR does not require any particular expertise in any other software or tools. If you know how to use a keyboard, mouse, and a web browser, you will be prepared for this course.

Other requirements/notes

The following software will be required in order to use this manual.

- Case Scenario/Critical Reader Builder - This tool can be obtained at http://engage.doit.wisc.edu/software/csb/gettool.html

- A Web Browser - It is recommended that you get the latest version of Internet Explorer, Google Chrome, or Mozilla Firefox.

- This manual was designed using the Windows version of CS/CR Builder, but Mac users should be able to follow along as well. Where keyboard shortcuts refer to the Control (Ctrl) key, Mac users should substitute the Command key. Other adjustments for Mac users are noted in the text.
Teaching is all about encouraging new ways of thinking and delivering information in an easily digestible format. However, we want to make sure we deliver content in an engaging and informational way. Case Scenario/Critical Reader Builder is a great tool for creating situations that put students in the position of making decisions based on contextual information. In the interest of brevity, we will refer to a Case Scenario/Critical Reader Builder project as simply a Case Scenario.

This section will cover different tools available that you can use to organize a Case Scenario. It will outline how to insert pages and create branching connections between the pages. First, however, we must create our Case Scenario project.

**Projects**

In CS/CR Builder, your Case Scenario will be organized into a project file containing all of the pages, actions and media you have inserted. Before you can get started, you must create a project to work on.

**Creating a Project**

1. Open CS/CR Builder by going to your Start menu or clicking on the desktop shortcut (if it exists). (On a Mac, open CSCR Builder from the Finder’s Applications menu.)

2. You should see two buttons in the center. Click the button that says New Blank Scenario. Alternatively, you can go to File > New Project (Ctrl+N).

If you have been given an existing project file to work with, you can open that as well.
Opening an Existing Project

1. **Open CS/CR Builder.**
2. **Click** the button that says *Open Existing Scenario*. Alternatively, you could go to *File > Open...* *(Ctrl+O).*

Now you can start working on your project. First you must gain familiarity with pages.

Pages

In a Case Scenario, each encounter is organized into a series of pages. Readers will discover new information on each page and eventually make decisions to explore a branching structure of pages.

When you create a new scenario CS/CR Builder will ask you whether you want to start with single blank page or a blank split page. The difference is simply that a split page is divided into two columns called *Panes* and you can add information to either pane.

Adding Pages

1. If you have created a new page you will be prompted to select either a *Blank Single Page* or a *Blank Split Page*. **Click** on *Blank Single Page* for now.

2. Now **click** on the *Add Page* button, it looks like a white rectangle with a green plus on top. You will be prompted with the same *Select Type of Page* screen. **Choose** *Blank Split Page*.

3. When you create a new page it is by default titled “Untitled #”. To change this simply double click slowly on the text in the *Outline* column and type your new name.
Pages represent larger and more important checkpoints in the Case Scenario. Sometimes however you may run out of space to display all of your information on a single page, or have more of a linear progression at a specific point in your Case Scenario. Rather than creating more pages you can create Child Pages to organize closely related explorations together.

Another important use for Child Pages is to display various answers to the questions asked of the student exploring the scenario. Eventually you can use child pages to provide detailed responses to answers

**Adding Child Pages**

1. Select the page that you want to add a child page to in the Outline column.
2. Near the lower left-hand corner of the page editing area, click the Add Child Page button to create the child page.
3. You can also rename child pages. When you added the child page a box should have appeared on the bottom of the page editing area showing all of the main page and its child pages. Select and then slowly double click on the name of your child page to rename it.
Actions

Now that you can create pages and child pages for our project, you can begin to structure your complex branching scenario. Again, what makes Case Scenarios a great teaching tool is their capability to create non-linear investigations. Connections between pages, URLs, and attached documents in CS/CR Builder are done through *Actions*.

Typically, you will have already added content to the page before adding actions. You can attach actions to text, images, or objects like buttons.

**Attaching Actions**

1. **Select** an object on your page by clicking on it or, in the case of text, highlighting it.
2. **Click** the *Attach Action* button in the bar at the top.

![Attach Action Button](image)

3. **Select** one of the actions and choose a color for the link.

![Select an Action](image)

4. Depending on the actions you chose, do one of the following.
   - **Jump to Page** - Simply select the page you want to link to.

![Jump to Page Selection](image)
• Jump to New Page - Provide a name and specify whether the new page is a child page of the current page or a top level page.

• Link to URL - Provide the web URL and specify whether you want the page to open in the same window or not.

• Open File - Click on Browse and select the file you wish to link.

• Show Popup - Specify the title and content of a popup window that will appear.

• Send Report - Sends an e-mail to you with a score report (Quizzes are discussed later).

• Close Window - There are no options available. This only works if the action is within a popup window.

• Show Rollover Text - Write a message that will appear when the mouse rolls over the text.

Once you have attached an action to content on your page, the student can click (or rollover) the content on your page and the Action specified will be performed.
Inserting Content

Once you have created a page, you must populate with content that engages and informs the reader. In a Case Scenario you can include content ranging from flat text and multimedia to interactive buttons and quizzes. This section will cover the various ways you can insert and format content.

Text and Headers/Footers

The simplest form of content you can add to a page is text. CS/CR Builder provides several ways of formatting text content to make it as effective as possible. If you have ever used a rich text editor on the web, most of the options available to you should seem familiar.

**Adding and Formatting Text**

1. To add text, simply **select** the page (and panel if it is a split page) you would like to add text to. Click in the content area and begin typing.

2. **Select** text and click one of the formatting options available in the edit bar. You can apply bold, italics, underline, and strike through effects.

3. To align text **click** on one of the familiar left, center, right, or full justification options.

4. If you would like to turn some text into a list item **select** it and **click** either the bulleted or numbered list buttons.

5. You can also apply headings using the drop down on the far left of the edit menu.

You can also organize your text content into tables. This is done by inserting a numbered table.
Inserting a Numbered Table

1. **Click** the *Insert* button and select *Numbered Table* in the dropdown.

2. For each row in the table, begin with a pound symbol (#) and type a number, followed by the text for that row.

3. **Click** *Done* when you are finished.

Now you have successfully inserted a numbered table. There are two more details concerning the layout of a Case Scenario page.

**Headers and Footers**

In a Case Scenario a typical page is split up into a body section (potentially with two panes), a Header and a Footer. You can select the content that appears in the Header and Footer section of the page as well.

**Editing the Header**

1. **Click** the *Header/Footer* button and select *Edit Header*.

2. The workspace should switch to a header editor. You can add and remove content here just as you would normally. You can also choose a background color for the header here. If you like, you can replace the entire header with an image by checking the *Image Only* box.

3. **Click** *Done* when you are finished.
**Editing the Footer**

1. **Click** the *Header/Footer* button and **select** *Edit Footer*.

![Header/Footer button](image)

2. The workspace for the footer is slightly different than for the header. Rather than editing the area much like the body, you must add items individually to the list on the left hand side using the green plus button. You can delete them with the red “x”.

![Footer Items](image)

3. Now you can edit each item by selecting it and changing the content of it under the *Selected Item* heading.

4. When you are finished, **click** *Done*.

**Multimedia**

It is quite simple to incorporate video, images, and widgets into your case scenario. Adding multimedia can spice things up and make everything more aesthetically pleasing.

**Inserting a Picture**

1. In the top bar, **click** on the *Insert* dropdown menu.

2. **Select** *Image* from the menu.
3. Browse for the image that you would like to include in the project. Note: The image must be a .jpg, .gif, or .png.

4. Add *Alt Text* as desired. This is what is read if a screen reader is reading a webpage.

5. The *Align Text to Picture* dropdown allows you to change how the picture interacts with text.

6. **Click** *Done* to insert the image.

*Inserting a Video*

1. **Click** on the Insert dropdown menu, and select Video.

2. There are two options: Video file or YouTube

3. To insert a video file, browse for the video file on your computer.
CS/CR Builder

Software Training for Students (STS)

4. You can set Width and Height to dimensions that you need.
5. Notice there is a check box for Auto Play. This will play the video as soon as the slide appears.
6. To insert a video from YouTube, just paste a link to the desired video in the Video URL.

![YouTube Video Insertion Interface](Image)

7. Set the Width and Height to the desired dimensions.
8. If there is a specified start time you can input that as well.

This process of clicking insert and then locating a source is very similar for all multimedia. You will see the same sort of process in inserting web content.

**Embedding Content**

The CS/CR builder contains a very useful feature to embed content from the internet and your computer. There are several types of content we will show you how to embed, though the process is similar in most cases. Embedding content prevents you from having to recreate content in the CS/CR builder.

**Google Docs**

The first form of online content we will embed is a Google Document. The process is easy to complete on the CS/CR builder end of the spectrum, but it takes some preparation on the Google Docs website beforehand. The document you wish to embed must be publicly accessible before it can be embedded.

**Inserting a Document from Google Docs**

1. **Click** on the Share button in the upper right hand corner of the Google Docs document.
2. If the document is set to Private, **click** Change... and **select** the Public on the Web visibility option, then click save.

3. **Copy** the URL in the *Link to Share* box

4. **Click** on the Insert button in the CS/CR builder, select *Web Embed* from the dropdown

5. Paste the URL you copied into the *Embed URL* text box and click the Insert button

6. If the file was embedded successfully, a web embed box will appear with a green light. If it didn’t, the light will be red.

---

### Google Forms

Google Forms are a specific type of Google Doc which allows you create and store surveys in the cloud. The process for embedding a Google Form is similar to embedding a Google Document with some minor variations.

#### Inserting a Form from Google Docs

1. **Click** on the *More Actions* dropdown in the upper right hand corner of the Google Form.

2. **Select** *Embed* from the dropdown and **copy** the code in the popup box to your clipboard.
3. **Click** on the *Insert* button in the CS/CR builder, select *Web Embed* from the dropdown menu.

4. **Paste** the code you copied into the *Embed Code* text box and **click** the *Insert* button. Make sure that you are not pasting the code into the *Embed URL* text box.

5. If the file was embedded successfully, a web embed box will appear with a green light. If it didn’t, the light will be red.

**Qualtrics Surveys**

If Google Forms are not robust enough for your survey needs, Qualtrics is a web-based survey which has been made available to UW-Madison faculty, staff, and students.

Once you have created a Qualtrics survey you can embed it into your project by going through the following steps. This manual assumes you have already created your survey.

**Embedding a Qualtrics Survey**

1. Log into Qualtrics at http://survey.wisc.edu/ to access your survey. Make sure your survey is already active.
2. Navigate to *MySurveys* and find the survey you wish to embed and **click** *Send*. 
3. Paste the URL given into the following iframe element after the src as shown.

```html
<iframe src="https://uwmadison.qualtrics.com/SE/?SID=SV_25jo0KaQ3bHTIAQ" height="900px" width="800px">
</iframe>
```

4. In CS/CR Builder, click Insert and select Web Embed. Choose Code and paste the above snippet into the text box.

Widgets and Other Web Content

As you might have noticed, there is a similar process in all three cases, although Qualtrics surveys had the added complication of inserting the link into an iframe. In general, if there is a web service such as Twitter or Facebook that has a widget you would like to embed, these are the steps you will want to follow to insert them into your Case Scenario.

Embedding other Web Content

1. Navigate to the web content’s page with information about embedding into a personal website.
2. Copy the embed code or embed URL.
3. In CS/CR Builder, click Insert and choose Web Embed.
4. Choose URL if you copied a URL, or choose Code if you copied embed code.
5. Paste your code or URL into the text box.

**Buttons, Speech Bubble, and Tab Box**

Aside from text and media, there are also built in interactive elements and design elements that can be added to a page in CS/CR. Here you will learn to integrate some of these elements into a Case Scenario.

**Buttons**

Buttons are a simple way of including elements to your Case Scenario which help clarify that an action is performed by an element and that the reader can interact with it. The process for inserting buttons is essentially the same in each case, you just have to choose which button you wish to insert.

**Inserting a Button**

1. **Click** the *Insert* button.
2. **Choose** one of the available buttons in the drop down, you can see what options there are below.

3. The Previous and Next buttons will appear right away in your page and are decorated with arrows. **Double click** the buttons to attach an Action to perform.
4. If you choose just *Button*, choose a label for the button and decide which action you want the button to perform. Inserted buttons will default to “Back” or “Next”.

Now you have inserted your button.
Speech Bubble

Speech bubbles are a good way of indicating that someone is speaking. Inserting a speech bubble is a simple process.

Inserting a Speech Bubble

1. Click Insert and select Speech Bubble.
2. The Speech Bubble editing window should appear.
3. Select placement of the tip of the speech bubble, the width of the bubble, and the background color. Then write the text you want to appear.
4. Click Done.

Tab Box

A tab box is an object that has multiple tabs of content. Whichever tab the user has clicked, the content for that tab will be displayed.

Inserting a Tab Box

1. Click Insert and select Tab Box.
2. The Tab Box editor should appear.
3. To add or delete a tab, click on the green plus or red “x” respectively. They should appear in the left-hand column.

4. You select which tab to edit by clicking on it in the left-hand column. You can change a tab’s title and text content in the text boxes provided.

5. Click Done.

Now you have inserted your tab box. If you want to edit a tab box that exists already, just double click it in the page editor.

### Dialogue

In a Case Scenario, it is more effective if the information is not presented as stale facts. If you can work information into a conversation it can be more engaging. If you want to insert text formatted as a conversation between people, CS/CR has a Dialogue function to format it nicely for you.

A dialogue will consist of a series of child pages each with a dialogue object, typically a person speaking. You can then insert the series of child pages in a frame into a Case Scenario page. Here is how to create a Dialogue.

### Creating a Dialogue

1. Click the Insert button and choose Dialogue.

2. The dialogue editor should appear.

3. Dialogues work by having the user page through a number of child pages, each with text to simulate an individual speaking. To add a child page, click the green plus. Click the red “x” to delete a child page.

4. In the center of the dialogue editor is the dialogue frame. To choose an image for the person...
5. In the lower right corner are the options you can choose for jumping between the child pages of the dialogue. The Auto tab lets you select whether or not the previous and next buttons are present to move the dialogue forward or back a page.

6. The Manual tab will let you choose a specific page in the dialogue for the next and previous buttons to link to.

7. The Branch tab allows you to specify an action or text feedback based on the readers interaction with the dialogue. You can either type a text feedback in the box provided, or choose Jump Action and choose a page for the dialogue to go to.
8. When you are finished creating your dialogue, **click Done**.

Once you are finished, your dialogue will appear in a frame on the page you had intended to insert it into. If you ever want to edit a dialogue, you can simply double click on the frame.

**Quizzes**

Quizzes are a way of testing the user’s knowledge of the material previously presented in the Case Scenario. They vary widely in the types of questions that can be asked and the feedback they give.

Quizzes are a great tool but they are a little difficult to implement correctly. In this section we will go over the various types of quizzes and their uses, such as scoring.

**Quiz Questions**

There are four types of quiz questions build into the CSCR:

- Multiple Choice
- Short Answer
- Fill in the Blank
- Select All That Apply
This gives a wide array of options on testing user knowledge and here we will explore how they work.

**Inserting a Quiz Question**

1. Under the Insert dropdown, at the bottom *select* Multiple Choice.

2. *Question Content* will hold the Question. *Answer Content* will hold the Answer.
3. Under the *Selection* options, you can add or remove possible answers.
4. Selecting the correct answer is set in the *Scoring* section, which we will cover later.
5. *Select* Done.

**Inserting a Fill in the Blank Question**


2. You can now type out a sample sentence for the user to complete.
3. To insert a blank *select* Add Blank.
4. *Select* the blank and type in the correct answer(s) in the box below.
5. *Select* Done.
Scoring

Scoring works by using the cloud icon on questions that have been inserted. This scoring system is completely controlled by the creator of the case scenario. Based on scoring, you can redirect the user to a different portion of the case scenario, have them take a quiz again, or have them move on to the next part.

Adding correct answers to Questions

1. Go back to the Multiple Choice question created previously.
2. Select one of the answers. Select the arrow pointing to the cloud.
3. Give the ID of Q1_1. This just means Quiz 1 Question 1. Use meaningful names for ID’s
4. Description is a place to write notes pertaining to the specific answer.
5. Score/Data is a section where you can designate the weight of this correct answer. This is an opportunity to give partial credit and choose what questions are more important based on the number of points the user receives for getting it correct.
6. Set the Marker to Start, denoting that this question is the start of a scoring block.
7. Notice that each answer to the question has these scoring options, so there can be more than one correct answer.
8. Once you have completed each step, select Done.

Inserting a Scoring Display

Scoring displays are a way of notifying the user how they did in the quiz. Here is how to insert a Scoring Display.

1. Under the Insert menu, select Score Display.
**Inserting a Score Redirect**

1. Under the Insert menu, **select** Score Redirect.

   ![Image of Score Redirect](image)

   **Prompt** – Score Redirect

   ![Diagram](image)

   - If score is...
     - greater or equal, load Untitled 1 in Same Window
     - 10
     - less than, load Untitled 1 in Same Window

2. Here you can input a score the user needs to meet the “Passing” condition.
3. Then **select** the page the user should proceed to if they have passed.
4. Also **select** a page for the user to go to if they did not reach the desired score.

   Once all the fields are entered, **select** Done. You have now successfully created an automatically scored quiz to challenge the readers.

---

**Saving and Exporting**

You now have the knowledge to create a fully engaging Case Scenario, complete with complex branching and challenges for your readers. Once you have created your Case Scenario, you will have to make it available for the students to read. Here we will learn how to export your case scenario project and upload it to the web using the UW services Learn@UW and MyWebSpace.

**Saving and Exporting**

Case Scenarios made with CS/CR Builder are accessed by students in a web browser. So before you can upload your Case Scenario to the web, you will have to export it in a format that is viewable in a web browser.

Here is how you save and export a Case Scenario:
**Saving and Exporting a Case Scenario**

1. First you will want to **save your project** so you can work on it later. Do this by going to the *File* menu at the top and choosing *Save*. If this is the first time you have saved, you will be prompted to specify a file name and a location to save the project. Case Scenario projects have the file extension “.csbproject.”

2. Now you can export the project for the web. Again go to the *File* menu, but this time select *Publish*. This will save a “.zip” archive filled with the website files that you can upload to the web.

This will create a zipped archive with the necessary files for viewing on the web. Now you can begin to upload the Case Scenario to the internet.

**Uploading to the Web**

Once you have your Case Scenario exported, making it viewable to students is only a few steps away. Here we will cover Uploading an exported case scenario to the web using services provided by UW. As a student you have access to free web space through MyWebSpace, all you need is your NetID and password. We will upload a Case Scenario here and then link to it in Learn@UW.

**Uploading to MyWebSpace**

1. When you exported your Case Scenario it automatically compressed the related files into a zipped archive. The first thing you will have to do is **unzip** this archive. *Compressed files are not viewable on the web.*

   • On Windows, right click on the zip file and select Extract All. You will be asked to select a location for the unzipped files. Fill in any information the dialogue asks for and click next until the files are unzipped.

   • On a Mac, double clicking a zip file will automatically unzip it into a folder in the same directory as the zip file.

2. **Open** a web browser and navigate to http://mywebspace.wisc.edu to access MyWebSpace. If you aren’t logged in with your NetID already, you will be prompted to log in.

3. Navigate to the *web* folder **click Upload** in the upper right corner. You will see a link for *Advanced Upload*, this allows drag and drop uploading but requires that you have Java 5 or higher installed.
4. **Click** *Add Files* or drag and drop (in *Advanced Upload*) the unzipped folder to the advanced upload window.

5. Once you have selected all of your files **click** *Start Upload*.

6. Your Case Scenario is now on the web. You can get the web address for your Case Scenario by navigating to the uploaded folder in the MyWebSpace browser and finding *Index.html*. Right click on it and select *Open in Browser*. The URL for your Case Scenario will be in the address bar of your browser.

Your Case Scenario is finally available to be publicly viewable. Now you can link to it in Learn@UW to make it easily accessible to students. Here is how you can link to an uploaded Case Scenario in Learn@UW.

**Uploading to Learn@UW**

1. There is a known issue with images in projects uploaded to Learn@UW. To get around this, first upload your project to My Web Space using steps 1-6 above.

2. Log in to Learn@UW using your NetID.

3. Click on Content in the upper left corner to open Manage Content.

4. Click on New Topic and then Quicklink.

5. Select the Module where you want the content to be categorized, and then name your Quicklink using Title (i.e. My CSCR Project).

6. Finally, enter the URL for your project’s *index.html* page (see step 7 in Publishing to My Web Space).

7. When finished, click Save. *If you navigate back to *Content, the link to your CSCR project is now available for students to view within Learn@UW.