Citrix/XenApp: Problem with SmartCard or SSPI in Connection File

Symptoms

MAC users cannot launch applications and receive the following error message:

"Error in connection file "/Users/mitchbraselton/Library/Preferences/Citrix ICA Client/Modules": Cannot find section "SmartCard".

Error number: 11”

 SSPI

 

Causes

This issue occurs when "SmartCard, " is included in the Modules file of the ICA client on MAC client workstations.

Note: This issue has also been reported with SSPI instead of SmartCard.

 

Resolution

1. Open a text editor.

2. Browse to File-> Open > Users/myName/Library/Preferences/Citrix ICA Client/Modules

    OR /Users/Username/Library/Application Support/Citrix Receiver

3. Open the Modules file and edit the following line by removing "SmartCard, " from the line:
“VirtualDriver=Thinwire3.0, ClientDrive, ClientAudio, ClientPrinter, Clipboard, ClientManagement, ClientComm, ZL_FONT, ZLC, TWI, ICACTL, SmartCard, SSPI”

4. Save the file.

-Or-

Deleting the Modules file and restarting to have the system recreate a fresh new Modules file can also fix this issue.

It is recommended to make a copy of the original file before permanently removing from the existing location.

 

***********This article is based of the following article (http://support.citrix.com/article/CTX122289) on Citrix's Support website***********




Keywords:citrix xenapp smartcard sspi connection file remote access   Doc ID:30035
Owner:Noel K.Group:Computer-Aided Engineering
Created:2013-05-08 08:49 CDTUpdated:2016-08-15 08:53 CDT
Sites:Computer-Aided Engineering
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