EPD - eHelp - Technologies - Web Browsers

EPD recommends using the most recent version of Firefox, Chrome, Safari, Internet Explorer, or Edge.

Recommended Browsers

As a general rule, courses are designed to work on recent and up-to-date computing devices. It is safe to assume that if a computer is less than three years old, the computer will meet the minimum system requirements. However, to avoid any problems, it is recommended that an up-to-date browser version is used.
  • Note: You may experience display issues or other web browser incompatibilities from time to time depending on which web browser you use. Firefox seems to have the least compatibility issues overall, followed by Chrome. However, since all web browsers may have compatibility issues depending on the system, it is best practice to have multiple web browsers installed on the computer in the event of any difficulties with a particular website or learning system.
The most commonly used and supported web browsers are Firefox, Chrome, Safari and Internet Explorer. Download the latest versions at their websites.

Allow Pop-Ups

Some courses use pop-up windows. Therefore, pop-up blockers need to be disabled in the browser. Some blockers may be turned off in Windows by right-clicking an icon on the system tray (next to where the clock resides).


Courses use the following plugins for viewing or accessing course materials. See the related articles in eHelp for information on downloading, installing, and using the plugin.

Keywords:EPD eHelp technology   Doc ID:45665
Owner:Leah N.Group:Engineering Professional Development - Department Resources
Created:2014-12-16 12:20 CDTUpdated:2016-08-23 17:43 CDT
Sites:College of Engineering - Online Learning Resources, Engineering Professional Development - Department Resources
Feedback:  0   0