MyUW - Expired bug - Broken beta experience after May 2015 release

MyUW beta initially rendered a broken experience after the 20150-05-21 release for some users. This will no longer affect anyone since browser caches will have long since expired.

Nature of the problem

There's a resource caching issue such that some users accessing the MyUW beta after the 2015-05-21 release initially saw a broken page.

Screenshot of broken page

Workarounds available at the time

Thoroughly re-loading the page (discarding previously cached resources in the browser) should have resolved the issue. How to do this differs by browser and is documented in this wikipedia article.

Accessing the portal from a web browser that has not recently accessed MyUW beta should work properly without having to instruct the browser to re-load the page.

Hope for the future

There are continued opportunities to more specifically set cache headers so that web browsers will do the right thing without people having to manually tell the browsers to re-load content. The MyUW development team continues to consider options for navigating tradeoffs between performance optimization and ensuring that changes take effect.

(The MyUW team actually made some changes along these lines, which in some ways reduced but did not yet eliminate the risk of this problem.

See Also:




Keywords:refresh   Doc ID:51576
Owner:Will C.Group:My UW-Madison Portal
Created:2015-05-21 07:50 CDTUpdated:2015-09-01 11:45 CDT
Sites:DoIT Help Desk, My UW-Madison Portal
Feedback:  0   0