Office 365 - Troubleshooting Options

This document will provide an overview of tools and options that are available for troubleshooting problems that you will be using in conjunction with opening a case with our Office 365 Team.


  •  Remote Connectivity Analyzer
    • The Remote Connectivity Analyzer tool provided by Microsoft will provide a diagnosis and hopefully help pinpoint the cause of any errors you may experience when using an Outlook client. This often includes your client disconnecting after a period of time or not connecting at all. Follow the steps below to use this tool

      1. Navigate to https://testconnectivity.microsoft.com/.
      2. Click the tab labeled "Office 365."
      3. Click the bubble next to "Outlook Connectivity" or "Outlook Autodiscover" depending on which test you would like to perform.
      4. Fill in the fields as follows:
        • Email address: netid@wisc.edu
        • Microsoft Account: netid@wisc.edu
        • Password/Confirm Password: Your NetID password
      5. Make sure "Use Autodiscover to detect server settings" is clicked.
      6. Click the box next to "I understand that I must use the credentials of a working account from my Exchange domain to be able to test connectivity to it remotely. I also acknowledge that I am responsible for the management and security of this account."
      7. Enter the verification code and click "Verify."
      8. Click the button "Perform Test" located at the bottom of the page.
      9. From the tests results, there will be an icon located in the top right. When hovered over, it will read "Save as HTML." It would be useful to save this, incase you need to open a case in which you would then be able to provide us with this information.

        test results



  •  Office Configuration Analyzer Tool (OffCAT)
    • The Microsoft Office Configuration Analyzer Tool (OffCAT) provides a detailed report of your installed Office programs. This report includes many parameters about your Office program configuration. It also highlights known problems that are found when OffCAT scans your computer. For any problems that are listed in the report, you're provided a link to a public-facing article (usually a Microsoft Knowledge Base article) about each problem so that you can read about possible fixes. If you're a Helpdesk professional, you can also save the report to a file so that it can be viewed in OffCAT on another client on which the tool is installed.

      For Windows Clients

      For complete details on how to use this tool, review Microsoft's online documentation.

      For Mac OS Clients

      There is not Office Configuration Analyzer Tool (OffCAT) at this time.



  •  Inbox Repair Tool
    • This process will describe the process to repair your Offline Storage Table (OST) or Personal Storage Table (PST) file. This often helps clear up problems users may experience when working with email in an Outlook desktop client.

      For Windows Clients

      1. Make sure your Outlook client is closed.
      2. Navigate to "My Computer."
      3. Open your local disk drive (C:) by double-clicking it.
      4. Double click the folder labeled "Program Files."
      5. In the search field, type "scapst.exe." If you were unable to find the file, go back and click the folder labeled "Program Files (x86)"" and try the search there.
      6. Double-click Scanpst.exe. You will need to enter the .pst/.ost file you would like to repair. You can click "Browse" and navigate to C: > Users > your account > AppData > local > Microsoft > Outlook to search for the file you would like to repair.
      7. Click the "Start" button and wait for the scan to finish.
      8. run scan pst

      9. If any errors are found, you will be given the option to repair the file. Simply click the "Repair" button.

      For Apple Clients

      There is not inbox repair tool for Apple Clients at this time.



  •  Network Performance Troubleshooting video
    • The Network Performance Troubleshooting video is provided by Microsoft which will cover the most common issues causing performance problems when connecting to Office 365, how to test for them, and how to resolve them: view video.



  •  Recreate OST File in Outlook for Windows
    • An OST file (.ost) is an offline folder file in Microsoft Outlook. Offline folders make it possible for the user to work offline and then to synchronize changes with the Exchange server the next time they connect. The ability to work offline is useful in environments with limited or unreliable connectivity. If you encounter problems with an offline Outlook Data File (.ost), the file can be re-created by downloading a copy of your items again. We don't recommend repairing an offline Outlook Data File, so if your offline data file isn't usable, you should re-create it by doing the following:

      1. Make sure your Outlook client is closed.
      2. Use the instructions in the following document to locate the OST file: Outlook Data Files (.pst and .ost).
      3. Open File Explorer.
      4. Go to the folder location of the OST file and delete it.
      5. Close File Explorer.
      6. Restart Outlook.


  •  Enable Logging

    • Enable Logging

      For Windows Clients

      Microsoft Outlook has an option that allows the user to turn on logging for certain Outlook features. The log data that is created by this process would be collected and used to further troubleshoot a problem you are experiencing. Either our support staff or Microsoft's will be asking for this data, so follwo these isntructions to enable this feature in Outlook 2016, Outlook 2013, and Outlook 2010.

      1. Start Outlook.
      2. Click the File and from here click Options.
      3. Click the Advanced tab located on the left.
      4. Locate the section labeled Other and check the box labeled Enable troubleshooting logging (requires restarting Outlook).
      5. Exit and restart Outlook.

      After you have turned on logging, the files will be stored in a folder in the folder. By default, the Temp folder is located in the \AppData\Local folder.

      • c:\Users\username\AppData\Local\Temp

      After navigating to the files, you will want to highlight them all and then right click them and click Send to and click Compressed (zipped) folder so you can easily supply these to either our's or Microsoft's support staff.

      For Mac Clients

      These options are also available in Outlook for Mac 2011 and Outlook 2016 for Mac.

      • Outlook 2016 for Mac:
        1. From the Window menu, click Sync Errors.
        2. The Sync Errors window will appear, click the gear icon.
        3. Select the option labeled Turn on logging for troubleshooting and click OK.
        4. Close the Sync Errors window and restart your client.
      • Outlook for Mac 2011:
        1. From the Windows menu, click Error Log.
        2. The Error window will appear, click the gear icon.
        3. Select the option labeled Turn on logging for troubleshooting and click OK.
        4. Close the Error window and restart your client.

      Once you have enabled logging, it is a good idea to try and reproduce the problem you are experiencing and then disable logging by following the steps above again to deselect the logging option. You can find the logs located in the following locations:

      • Outlook for Mac 2011 : ~/Desktop/OfficeLogging
      • Outlook 2016 for Mac: ~/Library/Containers/com.microsoft.outlook/Data/Library/Logs/


  •  MFCMAPI Tool
    • For Windows Client

      Microsoft provides messaging application programming interface (MAPI) tool to help diagnose problems that are being experienced with Outlook. Please note that this tool is very powerful and is mainly used to delete corrupt data and once deleted it is permanently deleted. You can download the tool from here http://mfcmapi.codeplex.com/.

      Important: Because this tool is so powerful, we highly recommend that you only use this tool when working alongside a Microsoft Technician or Office 365 Support employee. This will ensure that nothing is accidentally deleted or corrupted while using this tool.

      One common problem that has been solved when using the MFCMAPI tool is an error that appears when trying to access certain options through the Outlook Web application. If you are experiencing an issue similar to this, then you can attempt to follow the steps provided below to resolve the issue. Before using this method, you will need to configure your Outloook desktop client and profile. For instructions on how to configure your desktop client, you can go here: Office 365 - Set up your mobile device or desktop client.

      •  Instructions
        1. Download the MAPI tool if you have not already, the link is provided above.
        2. Before continuing, ensure that an Outlook desktop client is not running and that you do not have the Outlook Web application open in your browser.
        3. Open the MFCMAPI tool on the machine you are using.
        4. Go to Tools -> Options -> and tick the boxes next to Use the MDB_ONLINE flag and Use the MAPI_NO_CACHE flag and click OK.
        5. Go to Session -> Logon... -> and choose your Outlook profile.
        6. Double click your mailbox from the list and it will open it in a new window.
        7. On the new page, right click Root Container and click Open associated contents table.
        8. On the Hidden Contents table tab, sort the columns header and scroll to the right until you see the Message Class details for each entry.
        9. For the three following entries, please Right click on the entry -> Delete Message -> Permanent Deletion (unless delete to deleted items retention is available)
          1. IPM.Configuration.Suite.Storage
          2. IPM.Configuration.OWA.UserOptions
          3. IPM.Configuration.Agregated.OWAUserConfiguration
        10. Once finished with the above steps, you can simply close the MFCMAPI tool by hitting the X button in the top right corner.
        11. Login to the Outlook Web application and determine whether or not you are experiencing issues accessing certain options.


  •  Support and Recovery Assistant
    • Microsoft provides the Support and Recovery Assistant to help diagnose issues that users may experience when using Outlook and Office 365. Unfortunately, this tool is not available for Mac users at this time. To use this tool, please navigate to the following site http://diagnostics.office.com/#/. Once there, you will need to download and install the application. Once you have installed the application:

      1. Run the application. Be sure to do this on the machine that is experiencing the issue.
      2. Select the application you are experiencing problems with.
      3. Select the problem you are experiencing and click "Next".
      4. You will be prompted for an Email address and password:
        • Email address: Enter the primary address of the account you are configuring - which will take one of the following forms: netid@wisc.edu, first.lastname@wisc.edu, or name@domain.wisc.edu.
        • Password/app password: enter the password of the account you are troubleshooting (from above).
      5. The tool with run some tests to try and troubleshoot the issue.
      6. After the tests have finished, click the button in the top right corner that says "Copy result" and save these results somewhere you can easily access later in case you need to open a case with us.
      7. Next the tool may try performing other troubleshooting steps depending on what it finds, click "Perform" or "Next" to allow the tool to run these troubleshooting steps.


  •  Fiddler

      1. Important: First, log out from Outlook on the web and close all browsers.

      2. Navigate to the Fiddler website.
      3. Download the Fiddler tool for your appropriate operating system.
      4. After installation, launch Fiddler.
      5. Once the tool is open, go to Tools > Fiddler Options.
      6. Make sure "Capture HTTPS CONNECTs", "Decrypt HTTPS traffic", and "Ignore server certificate errors" are selected, and then click OK.
      7. Next, choose File and make sure "Capture Traffic" is checked.
      8. Important: Next, open a browser, navigate to Outlook on the web, and check the Inbox.

      9. Once there, without closing your browser, go back to the Fiddler tool and choose File > Save > All Sessions... and save the file.



Keywords:Office 365 o365 tools troubleshooting microsoft office365 windows connectivity autodiscover enable logging OST repair support inbox remote mfcmapi remote analyzer tool recreate file diagnostic recovery fiddler   Doc ID:60885
Owner:Ara M.Group:Office 365
Created:2016-02-16 15:49 CSTUpdated:2016-11-29 16:44 CST
Sites:DoIT Help Desk, DoIT Tech Store, Office 365
Feedback:  0   0