Bucky Backup - Download, Install or Upgrade, and Configure the Client for Windows

This document explains how to download, install or upgrade, and configure the Bucky Backup client for Windows in a step by step process. The client allows you to connect to the Bucky Backup Enterprise, Lite, and Archive Services.

Note on Product Name Change

In 2017, IBM changed the name of the software we use for backups from Tivoli Storage Manager (TSM) to IBM Spectrum Protect. The change is mostly cosmetic. If you have been using Bucky Backup for a while you may notice that some things are different, like the program group name in the Windows Start Menu, but most of the underlying software is the same. For example, the install location and registry keys are the same as before, and the executables have the same names.

Download

This KB article provides direct links to client downloads, however, they may not always link to the latest clients. You can find information on the absolute latest client releases and fix packs from IBM here (look under the client section):

IBM Spectrum Protect Downloads - Latest Fix Packs and Interim Fixes

Download the client from IBM:

Install or Upgrade

Installing and upgrading are the exact same procedure. After an upgrade you shouldn't need to re-configure your client if it was working fine to begin with, but there are newer recommended settings, so it might be worth checking your current settings. If you're upgrading to a newer major version (for example: 7.1.3.0 to 8.1.4.0) it's recommended but not required to uninstall the old client first. 

  1. Extract the installer by double clicking on the file you downloaded.
  2. Click "Run" on the security warning box.





  3. A folder called TSMClient will be created in the same location as the download file. Open it and then double-click spinstall or spinstall.exe.



  4. Allow the app to make changes to your device.



  5. Select language (English).
  6. Install the Microsoft Visual C++ Redistributable packages if it asks you to.



  7. Click Next on the welcome screen.
  8. Use the default install location if possible.
  9. Select "Typical".



  10. Click "Install".
  11. Click "Finish".
If you upgraded from a previously installed client you it's not usually necessary to re-configure the client options, but you may benefit in going over the recommended settings in KB 83392:


Upgraders can stop here.

Configure the Client

Initial Configuration

  1. Find the newly created program group. It may be called IBM Spectrum Protect or Tivoli Storage Manager depending on the version the client you downloaded.
  2. Click "Backup-Archive GUI".



  3. Click "Yes" to allow the program to make changes.



  4. If it's your first time running the client, it will automatically start the Client Options File Configuration Wizard.
  5. Click "Next".
  6. Select "Create a new options file" and click "Next".



  7. Enter the node name you chose during registration (case insensitive)



  8. Use "TCP/IP".



  9. Enter the server and port that you were assigned. The server should be listed in the email you received during the registration process. Your server may be different than what's in this screenshot. Look up the correct port here: Bucky Backup - Servers and Ports



  10. Don't select anything for the Include/Exclude List.



  11. Don't select anything for Common File Exclusions.



  12. Backup type should be "Incremental". Most users should check the box for "Back up all local file systems". If you have local file systems that you want to exclude or mounted network file systems you want to include, uncheck the box and highlight them in the list.



  13. Click "Apply".



  14. Type in the password you selected during the registration process and click "Login".



  15. Click "Finish".
  16. In order to make further config changes you must exit and restart the client. If you start changing client configuration without restarting, your changes may not save properly. (This is likely a bug that will be corrected in a future version.)



  17. Exit the client by clicking the "X" or File -> Exit.

Minimal Configuration

The Spectrum Protect client has many options. The defaults will generally work for most users, but in order to allow the client do scheduled backups you must configure it to save the node password.
  1. Restart the GUI client by running "Backup-Archive GUI" from the program group.



  2. Enter the password for your node.



  3. Edit your preferences: Edit -> Client Preferences



  4. Go to the Authorization tab
  5. Select the "Password Generate" radio button.



  6. Click "OK"
  7. Exit the client by clicking the "X" or File -> Exit.
  8. Next time you start the client it will prompt for the password and save it.

Further Configuration

In order to keep this KB doc from getting too long, additional configuration options which are highly recommended are in a separate KB. Please see KB 83392 for more information.

Client Scheduler

Configure the client scheduler so that you computer automatically backs up.

If you have chosen "No Schedule" during the registration process because you will use your own tools to automatically run backup please stop here.
If you upgraded your client it's usually not necessary to reinstall or reconfigure the scheduler.
  1. Restart the GUI client by running "Backup-Archive GUI" from the program group.



  2. Enter the password for your node if it hasn't been saved already.



  3. Use the Setup Wizard: Utilities -> Setup Wizard
  4. Check the box for "Help me configure the Client Scheduler" and click "Next".



  5. Click "Next".
  6. Scheduler Task
    • "Install a new or additional scheduler" should be the only option if this is a new client install.
    • If you've upgraded from a previous version you could choose "Update a previously installed scheduler" or skip configuring the scheduler.
    • Click "Next".



  7. IBM Spectrum Protect Scheduler name and location
    • Use the default name "TSM Client Scheduler"
    • Recommended: Check the box for "Use the client acceptor to manage the scheduler"
    • Click "Next".



  8. Option File Name and Location
    • Use the default Option File Name
    • Click "Next".



  9. Authentication
    • Node Name should be already set to your node name.
    • Enter your node password.
    • Check the box for "Contact the IBM Spectrum Protect Server to validate password"
    • Click "Next".



  10. Service login options
    • Select "The System account"
    • Select "Automatically when Windows boots"
    • Click "Next".



  11. Use the default log file names.
    • Optional: Check the box for "Enable event logging" to send events to the Windows Event Log.
    • Click "Next".



  12. Start Option
    • Select "Yes".
    • Click "Next".



  13. Confirm and Apply your configuration
    • Click "Apply".
  14. Completing your configuration
    • Click "Finish".

Configuration Complete

You can now exit the client by clicking the "X" or File -> Exit.

The scheduler should be running, and your computer should backup during it's next backup schedule window.

Next Steps (optional)

Run a manual backup
Check logs
Verify Backups



Keywords:bucky backup tsm windows install upgrade configure config download client lite enterprise archive tivoli IBM Spectrum Protect ISP setup   Doc ID:80307
Owner:Kevin K.Group:Bucky Backup
Created:2018-02-20 18:22 CDTUpdated:2018-07-13 13:13 CDT
Sites:Bucky Backup, DoIT Help Desk
Feedback:  1   1