WiscWeb - WordPress UW Theme - Form Not Sending

This document will address the issue of forms not sending in WiscWeb. There are a few possible reasons that this could be happening.

Array Error

One of the reasons that forms are not sending is because the "from email" address is not set correctly in the form Notification Settings. When this happens, form submissions appear to go through but users are not receiving the submission emails as anticipated and an array error appears at the top of the screen:

Array error message

In order to utilize Gravity Forms technology in WiscWeb, you must always set a specific "noreply" email in the "From Email" portion of the form settings. This must happen for each of the forms you own.
  1. In the Dashboard, navigate to Forms
  2. Hover over your form and choose Settings > Notifications
  3. Hover over the Notification and click Edit to edit your Notification
  4. In the From Email field, type "noreply@email.wiscweb.wisc.edu" (without the quotation marks)
  5. Click on the blue Update Notification button to save your changes
  6. Repeat these steps for each form in your form list

Copy and Paste Error

Another common issue with the submission of Gravity Forms comes when users attempt to copy and paste information into their form. This can often carry over code that cannot be processed by the form.

If one of your users is having trouble submitting your form and the issue is not showing an array error like the one above, the issue might be that they are copying and pasting content in. Please request that they manually type in the content rather than copying and pasting.

Concatenated Emails in the Send To, Reply To, or BCC Fields

Multiple users have noted issues with attempting to add more than one email address to the "Send To," "Reply To," or "BCC" fields in the Notification Settings of a Gravity Forms form. Users typically attempt this by using commas (or a comma + space) to separate the addresses. 

CommasInSendToEmail.png

While this is something that Gravity Forms claims should work, we have found that it has varying success in WiscWeb and often results in forms failing to send correctly. Therefore, we suggest alternative options for achieving the same result:

  1. Create a new notification for each person that must be notified. They can easily be duplicated to keep settings consistent.
  2. If you want to send it to 2 people, add one email to the "Send To" field and one to the "BCC" field
  3. Utilize the Configure Routing option in the "Send To" area to send to different addresses based on the same criteria

Other Issues?

If you've ruled out array errors and copy/paste errors and your users are still having issues submitting forms in WiscWeb, please reach out to CMS Support for some help. Include your site URL and a description of the issue.

See Also: