Support News

Beginning June 2023: UW-Madison Box desktop applications for Windows require .NET Framework v4.8

Posted: 2023-05-18 11:24:04   Expiration: 2023-09-16 11:24:04

Disclaimer: This news item was originally posted on 2023-05-18 11:24:04. Its content may no longer be timely or accurate.

Older versions of Windows may be impacted by an upcoming change to Box Desktop Applications (Box Drive, Box Tools and Box for Office).

Beginning June 2023 future releases of Box Desktop Applications for Windows will require .NET Framework version 4.8. If you are running an older version of Windows desktop software, you need to ensure that the installed .NET Framework is at version 4.8. Installation or upgrades of Box Desktop applications will fail unless .NET Framework is installed at the correct version. 

For more information about this change, see Box Product Announcement, .NET Framework (v4.8) upgrade for Desktop Products

For assistance installing the .NET Framework please contact your local IT Support staff or DoIT Help Desk.

-- UW-Madison Box Team